Bring4th

Full Version: Insecure Connection
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Recently upgraded Firefox, and now I'm getting a notice that when logging in that bring4th.org is an insecure connection.

Is this something new or am I just noticing it?
There is something unique about the SSL security certificate and forums, but I don't grasp it fully. I have summoned Steve to see if he can enlighten us. We'll see if my summoning spell will work.
Ok just wanted to bring it up in case something was awry. If it's nothing you can delete this thread after the fact. I'll lay down a circle of salt.
A circle of salt to stop unwanted information theft.

I will add that to my IT troubleshooting repertoire.

You really do learn something new every day~  lol Smile
(04-20-2017, 12:44 PM)Icaro Wrote: [ -> ]Recently upgraded Firefox, and now I'm getting a notice that when logging in that bring4th.org is an insecure connection.

Is this something new or am I just noticing it?

Hi, Icaro!

Just wanted to mention that SSL is active on Bring4th.org and the store, but not if you log in through the forums.  

Without getting too into the weeds on the technical details, SSL requires all images on a site to also have URLs that start with https:.   We allow images to be uploaded to the forums, and people also link to non-secure images, which means SSL won't work without throwing warnings at you.  Since we don't want this to happen during forum browsing, we enabled SSL on the front page of bring4th.

So if you want to log in securely, simply go to https://bring4th.org.

We are hoping to have the insecure image issue fixed with the next version of the forums, but since we don't deal with financial information or sensitive/compromising data on Bring4th, we opted to go for user experience over whether someone's conversation is encrypted.

Soon, all of it will be encrypted (SSL) by default, so hopefully this message will become moot soon enough.

Thanks for the question!
Steve
Ok..it all sounds fine and good. Thanks for the quick reply Steve!
(04-20-2017, 05:42 PM)Coordinate_Apotheosis Wrote: [ -> ]A circle of salt to stop unwanted information theft.

I will add that to my IT troubleshooting repertoire.

You really do learn something new every day~  lol Smile

Yeah! And if luck isn't on your side you can always abandon the project and use the salt for margaritas.
Truly you are a wise saint Icaro Heart
Just wanted to make sure I followed up--the https issue is fixed now, you can log in securely and use the forums with either http or https.

Please make sure that when you add videos and images that your URLs are https and not http. Otherwise, the pages will still be secure, but the browser will nag you that there are insecure images on the page. This is not a problem, just a reality with web sites trying to show both https and http imagery and videos.

Thanks!
Steve
Thanks for the update!